jaaj-rs/flake.nix

18 lines
584 B
Nix

{
description = "Blazingly 🔥 fast 🚀 and memory safe JaaJ implementation in Rust 🦀";
inputs = {
nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";
};
outputs = { self, nixpkgs }:
let
supportedSystems = [ "x86_64-linux" "aarch64-linux" ];
forAllSystems = nixpkgs.lib.genAttrs supportedSystems;
pkgsFor = nixpkgs.legacyPackages;
in {
packages = forAllSystems (system: {
default = pkgsFor.${system}.callPackage ./. { };
lolcat = pkgsFor.${system}.callPackage ./. { features = [ "lolcat" ]; };
});
};
}